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This Guide – Start Here
This guide is a quick reference to help you get acquainted with what is new in Smaart v8,
written specifically for users upgrading from and familiar with Smaart v7.
If you are new to Smaart, or have had limited experience operating version 7, we would
strongly recommend consulting the full Smaart v8 User Guide (available via download from the
support section of rationalacoustics.com, or from within your software license account at
my.rationalacoustics.com) and/or the program’s extensive help files (found in the Smaart v8
“Help” menu).
While much of the measurement functionality and operational paradigms of v8 are the same as
those of v7, there have been some significant changes. Before simply diving into the software,
as most of us will do, it is highly recommended that you read at least the short section titled
“New in Version 8, Some Key Concepts” located just after the table of contents. It will help you
get your bearings as you navigate v8.
Also, remember that Smaart is an actively developing platform. The initial release version 8.0.0
includes the features and functionality detailed here. However new v8 “update” releases will be
published regularly over the coming months and years to add new features and mature the
platform, as well as to address Smaart’s inevitable “undocumented features” (a.k.a. bugs) and
the operating system changes that Microsoft and Apple offer up. These “after dot” updates are
free to all registered v8 licensees, and can be accessed from within your license account at
my.rationalacoustics.com. These periodic releases willl be announced on our website and via
our newsletter (which if you have not already done so, we would highly recommend signing up
for on our site).
One final note, please feel free to contact Rational Acoustics at support@rationalacoustics.com
for help with any Smaart issues, to report software bugs or to suggest/request new features
and functionality for future updates.
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New in Version 8 – Some Key Concepts
Smaart Version 8 expands the previous v7 GUI (Graphic User Interface) to provide greater
display functionality, measurement capability and refines its organizational and control
paradigms. In order to best understand these changes, familiarity with the following basic
structural concepts will be helpful.

Measurement “Groups” have become “Tabs”
In version 7, we organized and controlled our measurement configurations using separate
groups of defined Spectrum (single-channel) and Transfer Function (dual-channel)
measurements. By switching the active Spectrum or TF groups, we controlled what
measurements were actively configured and available.
In version 8, to organize and control our measurement environment we now use “Tabs” that
include both the active measurement configuration as well as the GUI configuration/layout.
Version 8’s tabs:
• Use mixed groups, groups that can contain both Spectrum and TF measurements
• Retain plot view, interface layout and captured data information.
NOTE: While v8’s Tabs can contain mixed groups, the control and data bars still reflect
only the type of measurement, Spec or TF, that corresponds with the active plot (as in v7).

Switching between Tabs allows us to quickly configure and re-configure Smaart’s measurement
environment with the fundamental restriction that only one tab can be active at a time in a
given Window . . . however . . .

Version 8 is a Multi-Window environment
V8 allows you to configure and simultaneously run multiple (multi-tabbed) measurement
windows across multiple displays – with the limits only being your display capability and
CPU/GPU capacity. Also, Smaart v8 includes some dedicated, special-purposed windows – most
notably, the broadband meters and the API Client Window.

Auto-Configuration
Smaart v8 has added a significant amount of automation to its measurement configuration in
order to streamline and speed up the process, increase consistency and reduce errors. This
guide details those additions.

Focus!!
Controlling Smaart v8 requires a basic awareness of which GUI element has the program’s
current focus – which window/tab/measurement /plot/dialog/control. This focus will
determine how Smaart interprets commands. Also, be aware of which settings and controls are
Global (effect all Windows, Measurements, Plots, etc) and which are only Window, Tab, Plot
and even Measurement specific. A basic list of this “control ownership” is provided at the end
of this document.
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Smaart v8 User Interface
The basic v8 interface is a familiar one for anybody coming from v7, though you will notice
some tweaks and enhancements that make this GUI more customizable. Each of the 4 Interface
bars (Tab, Control, Command and Data) can be shown or hidden. Additionally, the Data Bar can
be expanded horizontally to allow for longer trace names, and the SPL/Clock readout can be
hidden from the Control Bar.
The Interface Bar configuration is stored individually per Tab.
The Data Bar (left), Command Bar (bottom) and Control Bar (right) can each be toggled
in and out using their triangular show/hide widgets located in the margin between the
interface bar and the plot area.

The Tab Bar
This area of the interface shows the window’s configured Tabs and can be used to select the
active Tab. This bar is can be hidden from the view menu or with the hot-key [A]. Note: This
command is currently global – hide/show applies to all windows.
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The Control Bar
This area shows the controls for all engines of the active plot measurement type available in the
active Tab. It also includes the Window’s SPL Meter (which can be toggled in/out), as well as the
Signal Generator and view controls. The individual measurement engine control elements now
indicate their trace color in their border, and their hide/show controls have been moved to the
APL (Active Plot Legend) in the Data Bar. The Signal Generator control area has been expanded
in size and moved to the bottom of the Control bar along with the plot view controls. The
Control bar can be shown or hidden with the hot-key [O] or its triangular hide/show widget.

The Command Bar
This area holds 10 user-configurable 'buttons' that trigger specific hot-key commands. These
buttons are configurable from the Config menu (Menu Bar > Config > Command Bar Config),
can be set to activate any Hotkey command, and can even be given user-definable names. In
conjunction with the addition of the Command Bar, we have significantly increased the number
of Smaart’s functions accessible via HotKey. The command bar can be shown or hidden using
the hot-key [U] or its triangular hide/show widget.

The Data Bar
Smaart v8’s Data Bar is currently divided into two sections. The Top section of the Data Bar
contains the APL (Active Plot Legend). The APL shows a listing of the traces available (currently
loaded into RAM) to display in the active plot. This includes both Live measurements (square
icons) and static data (circular icons). The APL trace icons indicate the trace color and its
current display (hide/show) status. It also displays the current trace offset if one has been
applied. Traces can be removed from the APL by selecting a trace and clicking the [Clear]
button. Traces can be moved back into the APL by capturing new data, or by clicking+dragging
a stored trace from the Data Library.
The lower section of the Data Bar contains Smaart’s Data Library. This shows reference traces
captured to file. When a measurement trace is captured in v8, it is stored in the APL (RAM) for
immediate display and written to a file in the data library (written to disc). Deleting a file from
the Data Library deletes that file from your hard drive (places it in your trash). From the Data
Library’s drop-down menu, you can set the root file on your hard drive that the data library is
accessing and writing to. From the File menu, you can import traces and trace folders into that
root folder (or you can just drag them into the data library window from your OS’s file system.)
The data bar can now be resized horizontally by clicking and dragging it horizontally from its
rightmost border. The Data Bar can be shown or hidden using the hot-key [B] or its triangular
hide/show widget.

V8 Application Start:
When you launch v8 you will be presented with one of two dialog boxes depending on whether
you are launching it for the first time (or restoring defaults), or returning to the application.
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First Run / Restore Defaults
Launching the Smaart v8 application for the first time will prompt you with the message
“Smaart currently has no measurements configured. Please start this process by selecting your
input source(s).” dialog (see below). Restoring the program to defaults in Manage Config will
also cue this dialog after the program re-starts.

Selecting OK takes you to the IO Config. From here, select the device and channels you wish to
use for measurement and give them friendly names if you wish. Smaart will not allow you to
proceed until you’ve selected an input source.
Note: When “restoring Defaults”, all of Smaart’s Option settings are set back to their default
first run settings and the current measurement configuration is completely cleared. All
previously stored configurations still remain available from the “Manage Configurations” dialog.

Returning
When you first launch v8, you will be presented with the screen below, giving you three
choices.

Continue with the current configuration:
This is effectively the “do nothing” option. Selecting OK will close the dialog and present you
with the Smaart interface and program configuration exactly as you left it last run-time.
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Note: Checking the “Do not show me this again” option will make the “Continue with
current configuration” option the automatic behavior on start-up until “Restore
Defaults” is run from the configuration manager.
Create a new configuration:
Choosing this option will wipe out the measurement configuration (IO, Measurement and
Meter Configurations) but will leave all other current Options settings intact. This then puts
you back to ‘first run’ behavior for IO selection and measurement creation.
Select a previous configuration:
Choosing this option allows you to load a previously stored configuration from the Manage
Configurations dialog.

A Note about “Configurations”:
There are two types of configurations in Smaart, “Measurement” and “Program”, with the
former being a subset of the latter.
A Measurement Configuration refers to the settings created in the I-O Config, the
Measurement Config (Measurements, Tabs and Windows) and Meter Config. These are the
settings that define your measurement set-up and are wiped clean when the “create a new
configuration” option is chosen on start-up.
A Program Configuration refers to all of Smaart’s settings, its measurement configuration as
well as all options (e.g. command bar configuration, GUI Skins, cursor display preferences, etc).
The Program Configuration is what is stored and recalled from Smaart’s Configuration Manager.
Measurement data is not included in a Program Configuration.
Data and Configuration file location:
Smaart v8 will create a root directory folder named “Smaart v8” in the Documents area of your
computer to store Smaart data and Config files. Included are individual folders for stored
Configs, Logs, Skins, and Traces. This facilitates easier sharing of data between users, with less
digging through your computers HD library.

Copyright © 2016 Rational Acoustics LLC. All rights reserved.

9

The v8 Configurator: All-In-One IO, Measurement, and Meter Config
Configuration in v8 follows a relatively simple conceptual thread:
1. Choose your input devices and channels – Spectrum measurements will automatically
be created for all selected input channels
• Provide friendly names and calibration information for those devices/channel
(optional)
2. Create additional Spectrum, Transfer Function and Broadband measurements using
those sources
3. Create Tabs to organize your measurements
4. Create Windows as needed

The IO Config Tab
V8’s IO Config combines the two Audio Device Options dialog windows from v7, with a few
enhancements – most notably the addition of live input signal meters and the replacement of
‘ignore’ check box with a more intuitive ‘use’ button. In v8 we now ‘choose to use’ whichever
input devices and channels we wish to use.

The measurement configuration process begins with designating which devices and channels to
acquire measurement signals from. This window displays the current status of the devices. The
default is no sources checked for Input Devices and all sources checked for Output Devices.
When you select a device, its device detail (with input meters) shows up below. When an input
device is selected, the first eight (8) input channels on that device are also selected. For devices
with more than 8 channels, the remaining channels must be manually selected for use.
Note: upon selection of input channels, spectrum measurement engines will
automatically be created using the channel’s friendly name in the Default Tab.
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Changing the friendly name will correspondingly change the name of the
measurement engine.

The Measurement Config Tab
The Measurement Configuration dialog is a central location to manage measurement engines
(including their creation/deletion, duplication, and tab assignments) as well as Tab and Window
configurations.
Tabs
Tabs are effectively enhanced Groups from v7. They are containers for configured
Spectrum and TF engines. Each tab will remember its layout and measurement data.
Only one tab can be active in a window at a time.
Windows
Windows act as containers for Tabs. Windows are effectively multiple instances of
the Smaart GUI which can be displayed on any one, or across many computer
monitors. Multiple windows can be actively running simultaneously.
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The configuration tree on the left side of the dialog
displays the hierarchical structure of the current Smaart
measurement configuration with Windows – Tabs –
Measurements/engines. Here a user can add Windows and
Tabs, as well as copy Tabs between windows, or
measurements between tabs (click and drag).
NOTE: Copy is the default behavior for click+drag, so if you
wish to move a measurement without creating a copy of it,
you must de-select the Copy button in the lower left corner of the window.
The right-hand window in this dialog displays the Tab or Measurement engine detail info. Select
the tab or measurement detail being displayed by single-clicking the name of the target
measurement or tab in the configuration tree, or by using the up and down arrows to step
through the selected Tab/Measurement in the Configuration tree.
In the Tab and Measurement detail windows, you can rename the current Tab/Measurement,
create new measurements within that Tab, or rename, reorder, delete or change the color of
current measurements in the Tab.
Copying a Measurement will create a new engine with the same definition (name, input(s) and
color). This creates some consistency between duplicate engines in multiple tabs/windows.

The Meter Config Tab
Smaart v8’s Broadband Meters are configured as grids, where a user may define how many
inputs to monitor based on how big they make the grid. For example, monitoring 8 inputs could
be done in a row of 8 (8x1) or, 2 rows of 4
(4x2) or 4 row of 2 (2x4) and so on with as
many inputs as you choose. Besides selecting
on its tab in the Configurator, you can access
the Meter Config dialog by heading to the
Menu Bar > Config > Broadband Meters or
the hot-key combo [shift] + [Control] + [E].
Clicking the SPL readout or input meter area
of the broadband meters will also bring you
here.
The Broadband Meters grid is displayed as its
own Window, and can be resized and
placed/assigned to displays as needed. The user can choose to have it “always display on top”
or follow the standard z-ordering of windows in a display.
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Broadband Meter Config controls:
Number of Meters - Broadband meters are configured as simple grids. For example, typing 4x2
will create a window with 8 meters, in two rows 4 over 4. 8x1 would result in 8 inputs
horizontally, or 8x2 would offer 16 meters, 8 over 8 etc…
Show Meters - this is the same as pressing the [E] key, toggling
show/hide meter window.
Always on Top - enabling this feature will keep the Broadband
Meter window on top of all application windows, Smaart or
not, regardless of what window has focus.
Type - You can choose to display each inputs SPL readout,
Input Meter, or both.
See the Broadband Meters section of this document for more.

Automation of Measurement Creation
A lot of attention has been paid in v8 to automating the measurement creation process by
adding some basic logic to the program. In most cases, you won’t need to manually create a
Spectrum engine ever again. You will see this primarily in two ways;
•

Selecting the inputs of the devices you will be using automatically creates the
corresponding Spectrum engines, with the input’s Friendly Name as the engine name.
These engines will be put into the default window’s default tab.

•

Creating a TF measurement in any tab will automatically trigger v8 to create
corresponding Spectrum engines for the TF measurement’s signal pairs. Again, Smaart
will name the Spectrum engines using the Friendly Name as assigned in IO Config. If a
Spectrum measurement engine with that name/definition already exists in the tab
Smaart will recognize that and not create a duplicate.

Measurement Definition by Name: Singularity of Measurement Names
The measurement configuration process in v8 makes use of the following fundamental
concepts and rules to create a configuration environment where a Measurement Name
ALWAYS refers to the same measurement definition (type & input signals) and color
assignation. This creates consistency in our measurement configuration and helps for quick
measurement definition.
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Singularity of Measurement Name Definition – the Rules
Measurement names must be unique within a Tab – a Tab can’t contain two
measurements of the same name.
Within a measurement configuration, a given name for a Spectrum or Transfer Function
measurement shall always refer to the same type, input signal and trace color definitions.
In other words, all measurements with the exact same name (not case sensitive) shall be
restricted to having the same definition.
There can exist within a configuration, or even within the same tab, multiple
measurements of the same definition as long as they have different names.
These stipulations require the following behaviors within Smaart v8’s measurement
configuration mechanism with regards to measurement names:
• Upon creation of a new measurement
o if a name is entered that already exists in that tab, the user is prompted to
provide an alternate, unique name.
o if a name is entered that already exists in the configuration, the user is
prompted to
§ use the existing measurement’s input definitions (default choice –
just hit enter)
§ provide a unique name
• Upon modification of an existing measurement’s Name (where multiple
measurements with the same name exist.)
o If the name is changed to a unique name, the user is prompted “do you
wish to apply this to all [previous name]?”
§ If “yes” - the name change is applied to all of the measurements of
the same name in the current configuration.
§ If “no”- the name change is only applied the individual
measurement
o if a name is changed to one that already exists in the configuration (but not
in that tab), the user is prompted to
§ use the existing measurement’s input definitions
§ provide a unique name
• Upon modification of an existing measurement’s input signal definitions or color,
those changes are applied to all other corresponding measurements of the same
name.

On-The-Fly Measurement Creation
At any point, without going to the configurator, it is possible to add/create new measurement
engines into the Tab workspace you are currently on.
•

For Spectrum Measurements, press [CMD +S] on a Mac or [CTRL +S] in Windows.
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•

For Transfer Function Measurements, press [CMD+T] (Mac) or [CTRL+T] (Windows).

These commands open up the familiar ‘New ______ Measurement’ creation window, though
with new behavior for the Name field. As you type the name of a measurement, Smaart will fill
in the rest until a unique name has been entered (see above). This is very much like typing a
search term into The Google, where it auto-populates search terms based on common ones,
however in our case these common names are engines you’ve already created in other tabs.

Note: When you create a TF measurement, Spectrum measurements for its corresponding inputs
will automatically be created in that tab if they do not already exist.

Duplicating & Moving Measurement Engines
Being able to quickly and easily copy an existing measurement engine (with all of its current
settings) from one tab to another is done by selecting an engine in the Measurement
Configuration tree, and dragging it into a new tab within the tree. Copy is the default operation,
though if you wish to instead move an engine out of a tab and into another, first de-select the
‘Copy’ button below the configuration tree.
NOTE: Copying an engine also copies all its current settings (delay, preferred plot, etc) whereas creating
a new measurement by choosing from the existing list of measurements only copies the measurement
definition and color.
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Tabbed Workspaces

Smaart v8 supports many workspaces, configured as Tabs, and assigned to application
Windows. Tabs replace Groups from v7. However, where Groups were only composed of
configured Spectrum and TF engines, Tabs are composed of 3 elements:
1. Layout: the display status of the Program Bars.
2. Plot View: The Plot area arrangement
3. Measurement Configuration: the assigned Spectrum/TF engines
There are no software limitations to how many Tabs may be configured or assigned to any one
window. Deleting a tab will also delete the measurements engines within. Users are prompted
to continue in such case.

Creating Measurement Tabs
Tabs can be created in 3 locations: the
Measurement Config tree, Config menu drop
down or by right selecting on an existing tab
and selecting ‘create’. In addition to creating
a new tab, right-clicking a tab shows you
options to Copy, Delete, Rename, or Move
to new Window (see Multi-Window
Interface). In all of these cases you are
presented with an empty tab in which you
will then have to populate with
measurement engines. It is worth noting
here that anytime you create a transfer
function engine, its corresponding inputs
Spectrum engines will automatically be
created (with their name being the inputs friendly name(s)) and added to that tab (if they do no
exist there already).
Anytime you select Copy Tab, a new tab will be created already populated with a complete
copy of the current tab.
In all cases, when a new tab is created it is added to the current window and the user is
prompted to provide a new name (with a default name provided).
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Destruction of Tabs
Tabs can be deleted directly by right selecting on one and choosing the delete option.
Alternatively, you can select on a Tab in the configuration tree and select the delete button. In
both cases, the corresponding engines built in the tab will be deleted.

Regarding Operation Mode Behavior and Tab Layout: Operation Modes (Real Time and Impulse
Response), are designated per window of Smaart. It is not possible to have one tab in IR mode
and another in Real Time mode simultaneously. However, because Tabs will remember their
layouts, as soon as you switch modes the tab will go back to its previous layout and plot view
configuration.

Multi-Window Interface
Smaart v8 allows any number of application windows – effectively a duplicate Smaart interface.
A Window is essentially a placeholder for Tabs. That said, each Window has only one active Tab.
Windows can be scaled and shown on any display connected to the host computer.

Creation
Windows are added from the Config menu
or from the Measurement Configuration
tree. New windows are given a default tab
with a Spectrum plot view and the Data
Bar, Control Bar, and Command Bar
showing.
Naming
The only time Smaart will ask you to name
a window is when you create one in the
Configurator via Measurement Config.
Window names can be changed from the
Configuration Tree by right selecting a
Window and choosing “Rename” or from Menu Bar > Window > Rename Window.
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Destruction
Individual windows can be closed from the Window menu or by using the X in the corner of the
window. Closing a window prompts you to either consolidate the tabs into the remaining
window, or discard (delete) them. Closing the final window will close Smaart.

Data Storage & Active Plot Legend
Smaart v8’s Data Bar is currently divided into two sections.
The Top section of the Data Bar contains the APL (Active
Plot Legend). The APL shows a listing of the traces
available (currently loaded into RAM) to display in the
active plot. This includes both Live measurements (square
icons) and static data (circular icons). The APL trace icons
indicate the trace color and its current display (hide/show)
status. It also displays the current trace offset if one has
been applied. Traces can be removed from the APL by
selecting a trace and clicking the [Clear] button. Traces can
be moved back into the APL by capturing new data, or by
clicking+dragging a stored trace from the Data Library.
The lower section of the Data Bar contains Smaart’s Data
Library. This shows reference traces captured to file. When
a measurement trace is captured in v8, it is stored in the
APL (RAM) for immediate display and written to a file in
the data library (written to disc). Deleting a file from the
Data Library deletes that file from your hard drive (places it
in your trash). From the Data Library’s drop-down menu, you can set the root file on your hard
drive that the data library is accessing and writing to. From the File menu, you can import traces
and trace folders into that root folder (or you can just drag them into the data library window
from your OS’s file system.)
The data bar can now be resized horizontally by clicking and dragging it horizontally from its
rightmost border. The Data Bar can be shown or hidden using the hot-key [B] or its triangular
hide/show widget.
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Broadband Meters
The broadband input signal(s) of any number of available device inputs can be monitored
simultaneously via the Broadband Meter window. Opening the Broadband Meter window
displays a fully scalable meter bank, which is wholly separate from the RT and Impulse
Response views. Access to this window is found in the Menu Bar > View > Broadband Meters,
or simply by pressing the hot-key [E].

The Smaart IO's controls will be displayed on the side of its input meter (á la v7 Di). You can
change the interface and channel feeding a configured broadband meter on the fly using the
drop downs above the input meter. Also, single selecting within the broadband readout, or in
the full scale meter, will open the Broadband Meter configuration dialog.

Logging and LEQ
Once you've enabled logging from the Broadband
Meter Config, you can choose any of the available
meters to log from. A file for each input will
automatically be created in the designated
logging path.
If you do not select the master Enable Logging
box, nothing will be logged, regardless of what
you have selected under the Log column.

SPL Meter Names
The Name column of the Broadband Meter Config dialog names the upper-most portion of the
SPL readout only. This field is directly editable, and does not affect that input channel in any
other way. This is especially convenient when you have configured multiple SPL meters of
varying types fed from the same device input. You will notice that the Device and Channel
Copyright © 2016 Rational Acoustics LLC. All rights reserved.
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columns reflect the driver API name and Friendly Name for that input. The other fields are selfexplanatory.
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New Menu Bar Layout

It may not be immediately obvious how much the Menu Bar has changed or adapted over the
years. Though upon closer examination it is quickly apparent that the v.8 Menu bar has been
completely renovated, and is about as concise as can be while still remaining intuitive. As
always, menu items that can be accessed via a Hotkey command have those commands noted
on the right edge of the menu window.
Smaart Menu
This is the application menu for OS X. It doesn’t exist on Windows-based computer and
therefore contains no mission critical items.
File Menu
Certain actions which require you to import from, or otherwise
access, the file management system of your computer have been
moved here. About and Quit also remain intact from v.7.
The Import submenu refers especially to data pertaining to Real
Time Measurements. Traces, Target Curves, Weighting Curves, or
ASCII files may all be imported from here.
Impulse Response file operations are located in the File menu – you can load an IR file (.wav), IR
decay markers, and save both as well from here.
Config Menu
This menu provides access to all of Smaart’s measurement
configuration functions. Any item that has to do with setting up
Smaart for measurement can be found in this drop down. The top
portion of this menu is dedicated to providing access to Smaart’s
various measurement Configuration dialogs as well as to its
management tab for storing and recalling measurement configuration
snapshots.
You will notice that certain items are duplicated in other menus – New
Window for example. This is done for the sake of being intuitive
where, depending on the task at hand, it may make equal sense to go
looking for New Window in the Window menu as well as Config.
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Options Menu
Options specifically refers to the general user-adjustable Program
Settings which are stored in a standard Program Configuration which is
saved via Manage Configurations. This menu provides access to all of
the Smaart’s individual Options dialogs. With v7 this menu became
more and more of a catch-all for commands, which now have a rightful
place of their own in the command menu.

View Menu
The View menu houses all of the GUI configuration options in Smaart v8
including the Mode select, plot view presets and any settings which
change the actual presentation of Smaart’s interface, be it the tab
layouts, plot view configuration, or display state of Smaart v8’s new
windows (namely Broadband Meters and the Client Window).
The bottom of this menu is dedicated to the commands for toggling in
and out Smaart’s various program bars, with check marks to indicate
their current view status (check mark = showing).
This menu also houses the toggle between Smaart’s default high and
low contrast program “skins”.

Command Menu
Any action in Smaart which can be triggered via hot key can now be
found in the Command Menu. We’ve grouped these commands
together based on their function – i.e. plot controls, cursor controls,
trace controls, etc. All hot key commands can be triggered from the
command menu, providing direct access to Smaart’s many and
various commands – especially convenient when operating Smaart
without a keyboard.
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Window Menu
Being that v8 is a multi-window interface, the Window menu bar item
facilitates the basic usability features that you would expect from such an
interface.

Help Menu
Have a question about a function in Smaart? There are
hundreds of pages of searchable information here - why
not give the Smaart Help files a try? Or RTFM . . .

Command Bar & Command Bar Configuration
More and more, Smaart is being run on tablet style computers without easy access to a
keyboard. This of course makes using Smaart’s numerous and helpful Hot Keys a bit tricky.
Smaart’s new Command Bar gives you access to 10 buttons, which you can map to any of the
programs hot-keys.

Configuration of the Command Bar is done
via the Command Bar Config dialog,
located in the Menu Bar under Config >
Command Bar Config. You can give a
custom Name to any of the command
choices. The button text is a fixed font
value, and will automatically cut off any
characters that do not fit on one line. The
number of characters allowed depends on
the window size of the interface (i.e. full
screen vs. scaled).
If you do not wish to view the Command Bar in any particular Tab, hiding or showing it is easy;
from the Menu Bar > View > Command Bar, the hot key [U], or by selecting on the triangle
widget located on the bottom center of main interface.
The configuration of the Command Bar is global. It cannot be configured per window.
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New Hot Keys
Many of the new features in v.8 were clear candidates for new hotkeys. These commands are
listed here for your reference.
Show/Hide SPL meter in main window
Dark /Light Contrast Skin
New Tab
New Spec Measurement
New TF Measurement
New Tab
Broadband Meter Config
Tabs Show/Hide
Command Bar Show/Hide
Control Bar show/hide
Broadband Meter display toggle
Toggle Peak Hold (RTA)
Open Client Window
I-O Config

[Alt/Opt] + K
[Ctrl] > [Shift] + X
[Cmd] > [Shift] + T
[CMD] + S
[CMD] + T
[Shift] > [Cmd] + T
[Ctrl] > [Shift] + F
A
U
O
E
P
[Alt/Opt] + R
[Alt/Opt] + A

Smaart v8 API & Client Window
V8 offers a new method for portable system measurement, the v8 API and the Client Window.
Any computer running v8 can act as a host to any other copy of v8. The Host computer does all
the heavy lifting – it is the one acquiring the measurement signals and performing the
mathematical computations. Any additional computers running Smaart v8, acting as ‘clients’,
may remotely access the measurement data. This also includes sending commands to the host
for necessary measurement processes, such as starting and stopping the signal generator,
activating Smaart’s delay finder, or capturing data.
The Client Window is a special application window that is used to remotely view measurement
data from another copy of Smaart v8 running on the Local Area Network. The Client Window
can also send basic commands to Smaart for controlling measurements and various
measurement settings.
**The Client Window is not backwards compatible with any other version of Smaart**
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A note about network speed
The network infrastructure and more importantly the transmission speed between the Client
Window and the Smaart server computer has an enormous effect on the quality and quantity of
measurements that you view in the Client Window. We recommend that at least one of the
computers, either the client or the server, is hard-wired into the network. If both computers are
wireless, you may experience problems with transmitting/receiving more than a few
measurements at a time.

Server Preparation
Before connecting to another copy of Smaart using the Client Window, ensure that all required
measurements and tabs are configured on the server side. Measurements and tabs cannot be
created through the Client Window, and are only populated upon connection. If measurements
or or tabs are reconfigured on the server after connecting with the Client Window, the window
must be closed and reopened to view the changes.
Also ensure that the API is enabled on the server copy of Smaart by going to Options -> General
and checking the “Enable API” box. If you’re prompted to allow Smaart through your firewall,
make sure you allow it. Note: The default port number 26000 is fine for most networks, do not
change it unless you have a good reason.

Accessing the Client Window
To access the Client Window, click View -> Client Window (or the Alt R hotkey). If this is the first
time you’re opening the Client Window, you may be prompted to allow Smaart through your
firewall. Make sure you allow it.
Smaart will scan your network for other copies of Smaart v8 with the API enabled (we’ll call
them servers) and will present a list of available connections. The IP address and the Hostname
of the server are displayed.

If Smaart cannot automatically detect an available server, you may need to check your firewall
settings or manually enter the IP address and port number of the server computer.
After the initial connection, the Client Window will scan the server side configuration and
present you with a list of available application windows. Choose the window that you want to
control.
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If only one window exists, the Client Window will just open to the main screen. All tabs from
the selected server window are mirrored in the Client Window.

Supported Measurements
Spectrum: RTA and Spectrograph
For RTA measurements, banding and averaging are applied on the server before sending the
measurement data over the network to the Client Window. Both settings can be changed from
the Client Window.
The Spectrograph is calculated locally in the Client Window based on the data displayed in the
RTA plot (coming from the server).
Transfer Function: Magnitude and Phase
Magnitude and Phase data is smoothed and averaged before it is sent over the network. Phase
smoothing, Magnitude Smoothing, and Averaging can be changed from the Client Window.
All Transfer Function delay controls are supported in the Client Window, with the commands
being funneled to the server.
Live IR is not currently supported in the Client Window.

Supported Commands
Most program commands and options related to the plot/window view are available in the
Client Window. Certain configuration commands such as New * meas * are not currently
supported.
The following commands/hotkeys are sent to the server:
Capture Trace
Toggle Signal Generator
Reset Averager
Toggle Delay Tracking
Activate Delay Finder
Increase Delay
Decrease Delay
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Signal Generator
The signal generator can be turned on and off and the level can be adjusted through the Client
Window. The signal type is displayed in the Client Window but cannot be changed.

Trace Capture
Capturing a trace in the Client Window captures the high-resolution measurement data into the
client computer’s Data Library regardless of what is being displayed in the window. A capture
command is also sent to Smaart on the server, using the same trace name that was chosen in
the Client Window. Note: changing trace names after they are captured and stored will not
propagate to the server.

Unsupported Measurements/Features/Options
Live IR
Impulse Response Mode (all)
Broadband Meters (and measurement engine meters)
Peak Hold
Instantaneous Response (Mag)
Unwrap Phase
Phase as Group Delay
Coherence Blanking
Toggle Coherence

Program Skins
In an effort to expand capabilities of customizing the user
interface, we’ve opened up the skin color picker for
various interface elements. While this may not be
something used regularly, it is entirely possible that you
may find a situation where altering the color of certain
plot elements may be desirable. The initial selections are
based on the default Light or Dark skin state when you
open the Skin Options dialog from the Options menu.
Once you’ve changed a parameter in the color picker,
choosing ‘Save As’ will prompt you to name it, adding
that new skin to the Skin Manager. Skins can be loaded,
renamed, deleted, and even shared. Sharing skins is done
by accessing the Skins root file directory, where you can
backup skins, and share them with others.
The default skins, as well as any configured skins, are not
deleted when you restore the program to defaults. You can delete the skins from the Skins
Options dialog, or alternatively accessing the root directory and putting them in the trash.
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Licensing, Registration, and System Requirements
Smaart v8 uses 3 blocks of 6 alphanumeric characters for its license codes (xxxxxx-xxxxxxxxxxxx). Just as with v7, register your license code to your my.rationalacoustics.com account to
access the v8 installer.

Minimum Suggested Computer System Requirements
Windows
Operating System: Windows 7 or newer (32 & 64 bit)
CPU: 2 GHz Dual-Core Intel i5 Processor or faster
RAM: 2 GB or greater
Graphics: Intel HD 4000 or better, or 256 MB dedicated video RAM
Display: Min. 1024x600 pixel display
Sound: Audio Hardware with OS compatible ASIO, Wav/WDM drivers.
Mac
Operating System: Mac OSX 10.7 (32 + 64 bit) or newer
CPU: 2 GHz Dual-Core Intel i5 or faster
RAM: 2 GB or greater
Graphics: Intel HD4000 or better, or 256 MB dedicated video RAM.
Sound Hardware: Audio Hardware with compatible Core Audio device drivers.

High Definition Display Support
Smaart v8 automatically detects and natively supports high definition displays (including Apple
Retina displays).
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Glossary of Terms
Active Plot Legend
The top portion of the Data Bar, listing traces that are located in the active plot, the trace
show/hide controls, and trace offsets. Data here is stored in RAM.
API
Application Programming Interface - The back-end interface that allows external programs to
send commands to and pull measurement data from Smaart.
Broadband Meters
A scalable SPL/input meter window that can be configured to monitor (and Log) any number of
available inputs. Includes IO controls for gain reporting devices (only Smaart IO currently)
Client Computer
Computer running Smaart v8 that is using the Client Window to acquire data from and control
measurements on the Host Computer.
Client Window
A dedicated window in Smaart v8 that provides API connection and control to a remote/host
copy of Smaart v8.
Command Bar
The program bar located below the plot area, containing user defined buttons. Any command
corresponding to a hot-keys can be assigned to a Command Bar button via the Command Bar
Config.
Configuration
All Smaart’s configuration data - Measurement configuration (engines, window layouts, tab
configuration, meters, IO settings) and all settings and options are saved and recallable as
configurations. Data is not contained in stored/recallable configurations.
Configurator
This dialog houses the IO Configuration, Measurement Configuration, and Broadband Meter
Configuration dialogs. Each can be accessed directly from the Config menu or viewed using
their tabs in the Configurator dialog.
Control Bar
The program bar to the right of the plot area, containing measurement controls, plot view
controls, the signal generator, and the SPL meter.
Data Bar
The program bar located to the left of the plot area. The data bar consists of the Active Plot
Legend (top) and the Data Library (bottom).
Data Library
The lower portion of the data bar, displaying stored Smaart data on your hard drive. The area
shows data from a designated root location on your hard drive – this can be user assignable.
Focus
The element of the Smaart environment that active commands will effect. These include the
Window, Tab, Plot, Measurement Engine and Control Element. When invoking a command,
particularly via hotkey or menu, it is important to know which elements of the Smaart interface
have Focus so that you know how the command will be enacted.
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Host Computer
Computer running measurements and serving data to client computers via Smaart’s API
Layout
A configuration of the Plot Area and Program Bars
Measurement Configuration
Smaart’s measurement configuration info - Measurement engines, window layouts, tab
configuration, broadband meter settings and all IO settings.
Measurement Engine
Or simply Engine, is the name given for configured single or dual channel measurements to be
activated for analysis. Measurement Engines use Global parameters unless otherwise specified
in the specific measurement engine details within the tab configuration.
Mode
The current operational Mode – either Real-Time or IR. This is Window specific, i.e. two
separate windows can be running in separate mode simultaneously.
Multi-Window Interface
Smaart v8 will run multiple windows as part of a single Smaart session pulling configuration
data from a single global measurement configuration. Windows can contain multiple Tabs.
Plot Views
The arrangement of plots in the plot area. Plot Views can be captured and assigned to a hotkey
from the View menu.
Program Bars
The 4 hide-able regions surrounding the plot area; the Data Bar, Tab Bar, Control Bar, and
Command Bar. Program Bar configuration is stored by Tab.
Program Skin
In addition to high and low contrast, users have the ability to create custom
color palates or custom colors for various buttons on the interface. The Skin Manager can be
accessed via the Option menu.
Tabs
The UI element and container comprising a Layout, Plot View, measurement engine group and
associated data. There can be only one active tab per window. Multiple tabs can be created
from the main UI, or from the Measurement Config dialog.
Tab Bar
The program bar located above the plot area, containing the tab UI elements, used to select the
active tab for a window. The Tab drop-down located in the Control Bar can also be used for this
task.
Window
Display area for the Smaart program. A window contains at least one active Tab and any
number of configured Tabs. When you start Smaart, the default window layout is all bars in,
with a single RTA plot view. With no configured measurements, Smaart will prompt you to
enter session configuration (a la v7).
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Configuration Ownership
The following is a list of the settings and controls as they apply to Smaart v8 configuration:

Set/Controlled Global:
• Spectrum and TF Global Measurement Settings
• Measurement Options (unless specifically noted)
• Skin (including High/Low contrast)
• Tab Bar Visible/Hidden State
• Broadband Meter Settings
• Client Window Settings
• Command Bar Settings
• Smaart Data Library
• Unique Measurement and Tab Names
• IO configuration (Names, Use, Calibration)
• Measurement Configuration (Window – Tab – Engine Definition)
• Signal Generator
Set/Controlled by Window:
• Window SPL Meter Source
• Active Tab
• Measurement Mode
Set/Controlled by Tab:
• Measurement Engines in Tab
o Run Status ea.
o Delay & Tracking Status ea.
o Non-global Measurement Engine Settings
• Layout (Command, SPL, Data and Control Bar Visibility)
• Plot View
• Static Data – visibility and preferred plot status
• Measurement Names Unique
Set/Controlled by Plot:
• Plot type
• Zoom
• Trace z-order
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